Alpha updated

Tony Garnock-Jones tonyg at
Thu Mar 31 09:09:17 PST 2005

Hi Bill - I'm seeing the same fault with the big.image obtained via make 
get-alpha on MacOS X as of right now.

   darcs pull -a                (on main branch)
   make get-alpha
   # muck about with the Makefile to avoid "uname -o"
   make clean
   ./vm big.image
   Image saveNamed: 'slate.image'.

--> same error (ten "Nil"s)

I haven't bootstrapped the VM/image myself yet.


Bill Sun wrote:
> I successfully rebuilt and bootstrapped the VM. 
> However, right after the bootstrapping process, when I
> tried to execute the save image command, I get this
> error message:
> ========================================================================
> Hi, there!
> Please save your image now, (eg. "Image saveNamed:
> 'slate.image'.") to
> eating this bootstrap.
> Slate 1> Image saveNamed: 'slate.image'.
> The following condition was signaled:
> -1 is not a key in {Nil. Nil. Nil. Nil. Nil. Nil. Nil.
> Nil. Nil. Nil}
> ========================================================================
> I tried some simple additions like "1 + 3." and they
> all end of with the above error message.
> Any ideas?  Did the windows files get out of sync?
> -Bill Sun

More information about the Slate mailing list