Problem trying PHP3 on

Alaric Williams
Mon, 20 Sep 1999 14:48:06 +0100 (BST)

On Mon, 20 Sep 1999, Paul Dufresne wrote:

> I tried a very simple example to show: Hello World!, but it failed
> with: Fatal error: Unable to open /serv/php3/~index.php3 in - on line
> 0 No input file specified.

Hum - I got that with the canonical test PHP3:

$ cat > test.php3



and got the same error basically - it looks like PHP3 is set up wrong.
Server admin dude, is it perchance set up as a CGI or something? I have it
set up as an Apache module on, with the following in

love$ grep php3 /usr/pkg/etc/httpd/httpd.conf
LoadModule php3_module lib/httpd/
AddModule mod_php3.c
AddType application/x-httpd-php3 .php3
DirectoryIndex index.html index.php3

I would grep around the config files on bespin a bit but I'm getting a
crap connection to it right now and typing commands is hell :-)


---==========================[ ]============---

	Almost three thousand years ago, I was on the comittee
	who designed Christianity... but it took us nine hundred
	years to get it past the risk assessment subcomittee :-(

---=========[ ]==================================---