Questions or comments

Brian Rice
Wed Mar 28 04:45:02 2001

>Hi Brian.
>>  >1- downloaded
>>  >as from the post titled "Proper Arrow code release".
>>  >In spite of its name, this is actually a zip file which I have
>>  >uncompressed in a temp dir
>>  That's your problem right there... don't unzip it. .pr files are
>>  loaded directly into a running Squeak image. I certainly didn't Zip
>>  it on my end externally to Smalltalk.
>When I downloaded the file it came with a
>extension, in spite of the fact that its URL is that
>of a .pr file. Supposing that a .pr file has the for-
>mat of a .zip file, i also tried to load the file without
>the .zip extension, as Squeak does not allow loading
>a project file with a different extension from .pr, but
>the following exception immediately popped out:
>Error: subscript out of bound (etc).

It sounds like the software you are using is trying to coerce things 
on its own. (Too smart for its own good.) You have two options: (1) 
somehow get it to not attempt coercion, and (2) access the URL from 
within Squeak.

I'm guessing that this is a Windows program you're using, as I 
noticed you mailed with Outlook Express. So I'm not sure how 
difficult (1) would be. Not all Windows programs give you all the 
options you need. I don't have a Windows system handy to test you're 
problem, either. (No offense, but this makes me really joyful. =) 
What is probably needed is to disable whichever program it is that 
coerces the .zip extension. At the very least, I'll ask Squeakers if 
anyone's seen this problem. You also might try using a different 
(i.e. simpler) web browser, whatever one you can get for your 
platform that is less than 40MB in size, as that will likely not make 
as many of those invisible choices for you. Actually, I tried getting 
the .pr with IE 5.0 on the Mac just now to test it, and it works 
fine. So IE might not your problem, but instead some third-party 
software. However, I noticed just now that loading the project stalls 
at the last point in progress, requiring Alt-period halting. :( So 
I'll put together a stable release and test it myself to see if I can 
get at least that to go away. But I don't see you're bug, so that 
makes me think it has to do with your platform's settings for 
handling internet files.

See if this is the problem, please. I'm sending your report to the 
Squeak mailing list to see if anyone's run into something similar.